MailService.exe Fails to Initialize (Does Not Listen on Port 17001)
Issue
When attempting to access your SmarterMail webmail you receive the error message:
MailService.exe fails to initialize (does not listen on port 17001)
Cause
SmarterMail attempts to read information from a performance counter that keeps track of current CPU usage. On some systems the performance counter library may be corrupt or incomplete.
Resolution
If you are a shared hosting customer the following steps must be performed by a support technician.
- Log into the server using Remote Desktop.
- Click Start > Control Panel > Programs and Features.
- Right click on Microsoft .NET Framework 4 Client Profile.
- Click Uninstall/Change.
- Select Repair .NET Framework 4 Client Profile to its original state.
- Click Next.
- When the repair is completed click Finish.
- Choose the Reboot Later option.
- Right click on Microsoft .NET Framework 4 Extended.
- Click Uninstall/Change.
- Select Repair .NET Framework 4 Client Profile to its original state.
- Click on Next.
- When the repair is completed click on Finish.
- Choose the Reboot Now option.
Once the server has rebooted you will be able to access SmarterMail webmail.
Article ID: 724, Created: June 12, 2012 at 1:08 PM, Modified: August 28, 2014 at 10:02 AM