Plesk Control Panel's Scheduled Tasks Do Not Run

Plesk Control Panel's Scheduled Tasks Do Not Run

Issue
When you open the Windows Scheduled Tasks control panel item, all Plesk originated scheduled tasks report a status of Could not start. When you try to bring up the properties on a scheduled task in the Windows Scheduled Tasks control panel item, you get an error similar to

General page initialization failed. The specific error is: 0x8007000d: The data is invalid.

Cause
The security information for scheduled tasks is corrupted, Windows no longer knows what account to run tasks under.

Resolution
This issue only impacts Windows Server 2003. You must have a dedicated server to perform these steps. Shared hosting customers need to open a support ticket for resolution of this issue.
  1. Use Remote Desktop to log into the server.
  2. Open My Computer and go to C:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\S-1-5-18.
  3. Delete all files that start with d42.
  4. Go to the Windows Scheduled Task Control Panel (Start > Control Panel > Right click Scheduled Tasks).
  5. Delete all Plesk related tasks.
  6. Log into the Plesk Control Panel. Click on Settings > Schedule Tasks.
  7. Click on any scheduled task, make no changes and then click OK.  This will cause Plesk to reset permissions on all scheduled task.

Add Feedback