Plesk Restore Fails with "Class Not Registered" and/or COM Error
Issue
When using the Plesk Restore tool to restore a backup or migrate a site, you receive an error. The details of the error contain the phrase "Class not registered" or "COM error"
Cause
This is caused by Plesk libraries and services becoming unregistered.
Resolution
- Log into your dedicated server using Remote Desktop.
- Click on Start > Run and executing the following command:
regsvr32 "%plesk_bin%\capicom.dll"
Article ID: 467, Created: April 9, 2012 at 4:07 PM, Modified: February 26, 2013 at 9:26 AM