Repairing a Domain’s IIS Application Pool

Repairing a Domain’s IIS Application Pool

Issue
When trying to visit a site, the browser pops up an authentication dialog requesting a username and password. This window may, for example, be titled "Connect to <site>" in Internet Explorer or "Authentication Required" in Firefox.
 
Possible Cause
The IIS application settings for the domain have become out of sync with the correct settings.
 
Resolution
You will need to reset or repair the domain’s IIS application pool.
 
Basic Repair Through the Control Suite
Shared hosting customers will need to contact support to request assistance with this issue. Dedicated server customers can follow the steps below or contact the support department for help.
Please note that any custom IIS configurations will need to be manually re-created upon completion of this process.
  1. Log into the server using Remote Desktop.
  2. Log into the Control Suite.
  3. Expand Plesk X.X.X (Domains).
  4. Select the domain name.
  5. In the Commands Ribbon, select Recreate Domain’s IIS.
    Control Suite Recreate IIS
  6. Click Yes.
  7. Once the Task Log reports Done!, the issue should be resolved.
 Advanced Manual Repair
Note: Please backup the site files and database before proceeding with this operation. If you feel uncomfortable about doing the advanced repair you may contact the support department for help.
 
Erase IIS Settings
 
Windows Server 2012
  1. Log into the server using Remote Desktop.
  2. Click Start by hovering in the lower left corner, or by hitting the Windows key on your keyboard.
  3. Expand the local computer account.
  4. Expand Application Pools.
  5. Expand Web Sites.
  6. Under Web Sites, locate and delete the domain name in question.
  7. Under Application Pools, locate and delete the pool with the domain name in question.
  8. Close IIS.
Windows Server 2003, Windows Server 2008, and Windows Server 2008 R2
  1. Log into the server using Remote Desktop.
  2. Click Start > Administrative Tools > Internet Information Services (IIS) Manager.
  3. Expand the local computer account.
  4. Expand Application Pools.
  5. Expand Web Sites.
  6. Under Web Sites, locate and delete the domain name in question.
  7. Under Application Pools, locate and delete the pool with the domain name in question.
  8. Close IIS.
Clear Plesk Site Cache
 
Windows Server 2012
  1. Click on Start > Run.  
  2. Type RegeditBack up the registry before making any changes to it.
  3. Delete the following registry key:
    HKEK_LOCAL_MACHINE\SOFTWARE\Wow6432Node\PLESK\PSA CONFIG\CONFIG\SitesCache
  4. Close the Registry Editor.
Windows Server 2008 and Server 2008 R2
  1. Click on Start > Run.  
  2. Type RegeditBack up the registry before making any changes to it.
  3. Delete the following registry key:
    HKEK_LOCAL_MACHINE\SOFTWARE\Wow6432Node\PLESK\PSA CONFIG\CONFIG\SitesCache
  4. Close the Registry Editor.
Windows Server 2003
  1. Click on Start > Run.  
  2. Type Regedit. Back up the registry before making any changes to it.
  3. Delete the following registry key:
    HKEK_LOCAL_MACHINE\SOFTWARE\PLESK\PSA CONFIG\CONFIG\SitesCache
  4. Close the Registry Editor
Reset Plesk Domain Settings
 
Plesk 12.5
  1. Log into Plesk.
  2. In the My Subscriptions section, click on the [domain].
  3. Click on the Change Web Hosting Settings button.
  4. Enter a new, unique username.
  5. Enter a new password and repeat that password.
    Note: You must enter a new username AND a new password.  This will not work if you use the old username or the old password.
  6. Click OK.
 
Plesk 12
  1. Log into Plesk.
  2. In the My Subscriptions section, click on the [domain].
  3. Click on the Change Hosting Settings tab.
  4. Enter a new, unique username.
  5. Enter a new password and repeat that password.
    Note: You must enter a new username AND a new password.  This will not work if you use the old username or the old password.
  6. Click OK.
 
Plesk 11
  1. Log into Plesk.
  2. In the My Subscriptions section, click on the [domain].
  3. Click on the Change Hosting Settings tab.
  4. Enter a new, unique username.
  5. Enter a new password and repeat that password.
    Note: You must enter a new username AND a new password.  This will not work if you use the old username or the old password.
  6. Click OK.
Plesk 9
  1. Log into Plesk.
  2. Click Domains.
  3. Find and click on the domain name.
  4. Click Web Hosting Settings.
  5. Enter a new, unique username in FTP/Microsoft Frontpage Login.
  6. Enter a new password.
    Note: You must enter a new username AND a new password.  This will not work if you use the old username or the old password.
  7. At the bottom of the page, uncheck Use dedicated pool.
  8. Click OK.
  9. Click Web Hosting Settings again.
  10. Re-check Use dedicated pool.
  11. Click OK.
If the issue was with the IIS application pool, this will have resolved it.

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