ERROR: PleskMainDBException

ERROR: PleskMainDBException

Issue
When trying to log into the Plesk Control Panel, you receive the error message below:
 
ERROR: PleskMainDBException
<b>Source:</b> Microsoft OLE DB Provider for SQL Server<br/><b>Description:</b> Login failed for user 'admin'.
 
0: plib\common_func.php3:624
    db_mssql_connection()
1: plib\common_func.php3:653
    reconnect()
2: plib\common_func.php3:614
    db_connect()
3: auto_prepend\auth.php3:80

Causes
This happens when Plesk is not able to log into its PSA database.  The most common causes for this are:
  • SQL is not running
  • The "admin" user's password was changed.
Resolution
Unless you have a dedicated server these steps must be performed by a member of our Support staff.

SQL is not running
Confirm MSSQL Server is running by double clicking on the Plesk Services Monitor.  If there is an X next to the MSSQL Server, check the SQL Server box and click the Start button.

The "admin" user's password was changed.
Step 1:  Reset the "admin" password in SQL.
  1. Log into the server via remote desktop
  2. Open SQL Server Management Studio and connect to the local server
  3. In Management Studio, Go to Security > Logins.
  4. Right-Click on the admin user and select Properties
  5. Under Password and Confirm Password, type in the new password and then click OK
Step 2:  Reset the "admin" password in Plesk.
  1. Click on Start > Run (or Windows - R).  Type cmd and press enter.
  2. In the command prompt, type (the quotes are required):  "%plesk_bin%\PleskSrvClient.exe"
  3. A Set Plesk Admin Password dialog will appear.  It will display an error message indicating that it can not connect to the Plesk SQL Server.  That is OK.
  4. Type in the same password you typed above and then click OK followed by Yes.
  5. You will now be able to log into Plesk with the password you entered.

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