Bug: IP Addresses Do Not Save and Always Reset to DHCP

 
BUG: IP Addresses Do Not Save and Always Reset to DHCP
This KB article requires you to make changes to your registry. Always back up your registry before modifying it. If you feel uncomfortable backing up or modifying your server's registry, please contact our support department for help with this matter.

Issue
When you open the Windows Control Panel and assign a static IP address to your server, the settings are not saved and revert back to DHCP.

Cause
This is a documented bug in the Windows 2003 and Windows 2008 operating systems.

Resolution
Delete the Existing Configuration's Registry Key
  1. Go to Start > Run > RegEdit.
  2. Navigate to: HKEY_LOCAL_MACHINE \SYSTEM\CurrentControlSet\Control\Network.
  3. Delete the key named Config.
Regenerate the Registry Value
  • In Windows 2008 go to Start > Control Panel > Network and Sharing Center
    1. Click on Change Adapter Settings. Right click on the network adapter and select Properties
    2. Do not change anything.  Simply click OK.
  • In Windows 2003 go to Start > Settings > Control Panel > Network Connections.
    1. Right click on the network adapter and select Properties.
    2. Do not change anything.  Simply click OK.
Re-add the Correct IP Address in Plesk
 
Plesk 12 and 12.5 Instructions
  1. Login to Plesk on the server.
  2. Click on Tools & Settings.
  3. In the Tools & Resources section select IP Addresses.
  4. Click the Add IP Address button.
  5. In the Add IP address page fill out the form with the dedicated IP address of the server you are trying to add.
  6. Click OK to assign the IP address to the network interface card.

Plesk 11 Instructions
  1. Login to Plesk.
  2. Click on Tools & Settings.
  3. In the Tools & Resources section select IP Addresses.
  4. Click the Add IP Address button.
  5. In the Add IP address page fill out the form with the dedicated IP address of the server you are trying to add.
    Plesk 10 IP Address
  6. Click OK to assign the IP address to the network interface card.
Plesk 9 Instructions
  1. Login to Plesk.
  2. Click Settings.
  3. Click IP Addresses.
  4. In the Add IP address page fill out the form with the IP address of the server you are trying to add.
    Plesk 9 add IP address
  5. Click OK to assign the dedicated IP address to the network interface card.

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