You Receive an Error When Browsing the Site, Server Error in '/' Application Configuration Error: Possible Permission Configuration Error
Issue
When you browse to your URL on your site, you get a message similar to the following:
Server Error in '/' Application
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request.
Possible Cause
File permissions are not correctly configured and certain files can not be accessed correctly.
Resolutions
- Reapply the permissions through the Control Panel.
- Use Control Suite to reapply the permissions (for dedicated server customers).
Reapply Permissions to the Httpdocs Folder of Your Domain Through the Control Panel.
- Plesk 12x
-
- Log into your Control Panel.
- Under My Subscriptions click the Manage Hosting link for the domain
- Click Websites & Domains > File Manager > httpdocs.
- Either search or scroll until you find the file called web.config.
- Hover your cursor over the web.config file until the drop-down arrow shows and click the drop-down menu to choose Change Permissions
- Once the page loads make sure that any applicable users have full control on the files.
- To do this, select the an user (ex. Plesk IIS WP User), click the Advanced button and check the Full Control permission box for the account in the right hand side.
- Once the permissions have been selected, click OK to apply the changes.
- Once the Control Panel has finished loading, refresh the webpage to ensure the issue has been fixed.
- Plesk 11x
- Log into your Control Panel.
- On the Domain tab click the domain
- Click Websites & Domains > File Manager > httpdocs.
- Either search or scroll until you find the file called web.config.
- Click on the Yellow Padlock icon to the right of the web.config file.
- Once the page loads make sure that any applicable users have full control on the files.
- To do this, select the an user (ex. Plesk IIS WP User) and check the Full Control permission box for the account in the right hand side.
- Once the permissions have been selected, click OK to apply the changes.
- Once the Control Panel has finished loading, refresh the webpage to ensure the issue has been fixed.
-
- Log into your Control Panel.
- Click Home tab then Domains > [Domain] > Files > Web Directories.
- Once the page has loaded, either search or scroll until you find the file called web.config.
- Select the check box next to the file and click Directory Access Permissions at the top.
- Once the page loads make sure that any applicable users have full control on the files.
- To do this, select the an user (ex. Plesk IIS WP User) and check the Full Control permission box for the account in the right hand side.
- Once the permissions have been selected, click OK to apply the changes.
- Once the Control Panel has finished loading, refresh the webpage to ensure the issue has been fixed.
Use the Control Suite to Fix the Permission Issue.
- Use Remote Desktop to log into the server.
- Open the Control Suite by double clicking the icon on the Desktop.
- The username and password of the Control Suite should automatically be entered so you just need to click Log In.
- Click OK on the second popup and the wait until the Control Suite finishes loading.
- Expand Plesk x.x (Domains) and click on the domain you wish to re-apply permissions.
- Click on the Reapply Permissions from the tool bar at the top.
- Refresh the webpage to ensure the issue has been fixed.
Article ID: 397, Created: April 9, 2012 at 2:43 PM, Modified: October 8, 2015 at 5:19 PM