An Error Occurred During the Processing of a Configuration File Required to Service This Request
Issue
When you browse to a URL on your site, you get a message similar to the following:
Server Error in / Application.
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request.
Cause
File permissions are not correctly configured and certain files can not be correctly accessed.
Resolutions
- In the shared hosting environment, fix permissions to the httpdocs folder of your domain in your Control Panel
- In the dedicated server environment, use Control Suite's Reapply Permissions button.
Fix Permissions to the Httpdocs Folder for Your Domain in Plesk 12.x
- Open up your Plesk Control Panel.
- On the Domains tab click on the domain name.
- Click on the Websites & Domains tab.
- Under your domain, click the Show More, if it is not already expanded.
- Click on the File Manager icon.
- Hover of httpdocs and click on the dropdown arrow that appears and select Change Permissions.
- Select the Application pool group user and check Full Control.
- Check Replace permission entries on all child objects with the entries displayed here and click OK.
Fix Permissions to the Httpdocs Folder for Your Domain in Plesk 11.X
- Open up your Plesk Control Panel.
- On the Domains tab click on the domain name.
- Click on the Websites & Domains tab.
- Click on the File Manager icon
- Click on the padlock icon as pictured in the image below.
- Once the Permissions page has loaded, check to make sure that all users have full control on the files.
- To do this select the user (ex. Plesk IIS WP User) and check the Full Control permissions box for the account in the right sidebar.
- Once permissions have been selected, click OK to apply the changes.
- Once the Control Panel has finished loading, refresh the webpage to make sure this fixed the issue.
Fix Permissions to the Httpdocs Folder for Your Domain in Plesk 9.X
- Open up your Plesk Control Panel.
- Click Domains icon under the Domains option.
- Click on your domainname.com in the list.
- Click on the Drop down menu under the Files option and select Web Directories.
- In the Tools section click on Directory Access Permissions.
- Once the Permissions page has loaded, check to make sure that all users have full control on the files.
- To do this select the user (ex. Plesk IIS WP User) and check the Full Control permissions box for the account in the right sidebar.
- Once permissions have been selected, click OK to apply the changes.
- Once the Control Panel has finished loading, refresh the webpage to make sure this fixed the issue.
Use Control Suite's Reapply Permissions Button
- Log into your dedicated server using Remote Desktop.
- Double click on the Control Suite icon on your desktop. (If the icon doesn't exist, run NetStrap.exe in C:\netstrap\SystemControl.)
- Click on Login and click on Yes to accept the terms of the licensing agreement.
- Double click on the Plesk Domains icon.
- Select the domain that is giving you the error.
- Click on the Reapply Permissions button.
- Watch the progress bar at the bottom of the screen for a message stating the the permissions have been fixed.
- Refresh the page, clearing cache if necessary to ensure the issue was fixed.
Article ID: 248, Created: April 6, 2012 at 11:08 AM, Modified: October 6, 2015 at 1:08 PM