How to Fix Control Panel Redirect Loop
Issue:
When logging into the Parallels Business Automation - Control Panel, it continuously redirects from https://control.managed.com/cp/ to https://control.managed.com/cp/index.cgi/top/zone,home/p_le,1/ and back.
Cause:
The control panel communicates between the main control panel at control.managed.com and the shared hosting server. When third party cookies are blocked, Plesk on the shared server can't set a cookie, and throws itself into a redirect loop. This has been observed to occur in Google Chrome, Opera, and FireFox.
Resolution:
Google Chrome:
Method 1:
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Open the menu in the top right corner.
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Click Settings.
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Click Show advanced settings...
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Under Privacy click Content settings...
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Click Manage exceptions...
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Add [*.]powerdnn.com with Allow behavior as an exception.
- Add [*.]managed.com with Allow behavior as an exception.
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Click Done.
Opera:
- Click Opera in the top left to open the menu.
- Click Settings.
- In the left menu, click Privacy & Security.
- Under Cookies, Click Manage exceptions...
- Add [*.]powerdnn.com with Allow behavior as an exception.
- Add [*.]managed.com with Allow behavior as an exception.
FireFox:
- Open the menu in the top right corner.
- Click Options.
- Click the Privacy tab.
- Next to Accept cookies from sites, you should see Exception... and click it.
- Add powerdnn.com and click Allow.
- Add managed.com and click Allow.
- Click Close.
- Click OK.
The cookie from the shared server can now be set, and the control panel can be accessed as expected.
Article ID: 2009, Created: July 7, 2014 at 1:11 AM, Modified: January 24, 2015 at 11:50 PM