You Get an Forbidden Error When Attempting to Browse to a Folder on a DNN site

You Get an Forbidden Error When Attempting to Browse to a Folder / Enable Web Directory Browsing

Issue

When you browse to a folder such as http://www.MySite.com/portals you receive the following error message:
 
Forbidden
You do not have permission to access this document.

Causes
This is by design.  IIS will show the default document listed in that folder.  If no default documents exist, then it will show that error. By default, directory browsing is disabled.  Enabling directory browsing presents a risk to your DNN site because anyone who knows the URL of a file can bypass DNN's built in security and download it directly.

Resolution

If you still want to enable directory browsing, please follow these instructions:
 
Plesk 12.x
  1. Log into your Plesk Control Panel.
  2. From the Home tab, go to [Manage Hosting] > Websites & Domains tab > Show More > Virtual Directories >Directory Properties.
  3. Check the Directory browsing box.
  4. Click OK.
Plesk 11.x
  1. Log into your Plesk Control Panel.
  2. From the Home tab, go to [Manage Hosting]Websites & Domains tab > Show Advanced Options > Virtual Directories >Directory Properties.
  3. Check the Directory browsing box.
  4. Click OK.
Plesk 9.x
  1. Log into your Plesk Control Panel.
  2. Go to Domains [Domain] > Virtual Directories > Directory Properties.
  3. Check the Directory browsing box.
  4. Click OK.

Add Feedback