Error When Trying to Open Parallels Plesk Panel: SWKeyExFatalError

Error When Trying to Open Parallels Plesk Panel: SWKeyExFatalError

When attempting to login to the Parallels Plesk Panel you receive the error below:


Cause

The error above indicates that the Plesk registry.xml file is corrupt.

Resolution

  1. Open a run dialog box by going to:
    1. Windows Server 2003/2008/2008R2: Start > Run or Windows Key + R.
    2. Windows Server 2012: Windows Key > Start Typing RUN or Windows Key + R.
  2. In the run dialog type %plesk_dir%\admin\repository\.
  3. Look for the Registry.xml.
  4. Right click on the file and rename to Registry.xml.old.
  5. Once you have done this try to login to the Plesk Control Panel again. If done correctly a new file should be generate and you should be able to access Plesk Control Panel again.
  6. Once you get into Plesk you will see a screen about your license. You should see a message saying: "Warning: You are currently operating within the grace period of your product license. To update your product license, select the Retrieve Keys option on the License Management page."
  7. Follow this KB article to retrieve a new license key: Expired Plesk License (Warning: You are Currently Operating Within the Grace Period of Your Product License)

Add Feedback