Timeout Expired Error when Attempting to Backup or Restore Plesk Domains
Issue
When attempting to backup one or more Plesk domains or restore them from a Plesk backup, the following error is encountered:
Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.
Cause
Some domains and/or databases are too large to back up using the default settings.
Resolution
Adjust the ADO connection settings by editing them in the Windows registry. If you are a shared hosting customer, please contact Ssupport for assistance with this issue. Dedicated server customers can make the necessary modifications or contact Support. Always back up the registry before making any modifications to it.
Adjust the ADO Connection Settings
- Press Windows key + R > type regedit.
- Navigate to HKEY_LOCAL_MACHINE>SOFTWARE>Wow6432Node>PLESK>PSA Config>Config.
- Double click on ADOConnectionTimeout and modify the value data from the default of 15 seconds.
Adjust the ADO Command Settings
- Press Windows key + R > type regedit.
- Navigate to HKEY_LOCAL_MACHINE>SOFTWARE>Wow6432Node>PLESK>PSA Config>Config.
- Double click on ADOCommandTimeout and modify the value data from the default of 30 seconds.
For additional information see http://kb.parallels.com/en/1121.
Article ID: 1811, Created: January 24, 2013 at 4:20 PM, Modified: November 20, 2014 at 3:22 PM